User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

Quick Forum Search


Who's Online

Weekly Photo

 
Fall Camping
Fall Camping at Algonac State Park (Wagon Wheel Campsite #368) October 4th 2013.
 Views: 58
Posted by lazydays
Apr 19, 2014
in This Week's Photo Winner

Checkout My Rig

 
FL camping trip March 2014 001
 Views: 51
Posted by woodosgood
Mar 31, 2014
in Checkout My Rig

Recent Topics

What was your best MOD so far? by NJGuy
[Today at 12:07:49 PM]


Hello from Virginia newbie! by Glamping Grandma
[Today at 12:06:32 PM]


New to site from VA by Glamping Grandma
[Today at 12:01:04 PM]


The Music Game by vagov
[Today at 12:00:21 PM]


Shedding weight by suprz
[Today at 11:59:20 AM]


2014 Midwest Spring Rally by novagirl
[Today at 11:58:13 AM]


'91 Coleman Newport parts by motomails
[Today at 11:57:23 AM]


Hello from West Texas by Glamping Grandma
[Today at 11:57:11 AM]


Question about lift cable pully lube by Raycfe
[Today at 11:49:56 AM]


Boxes or Tuppers?....for separating the items that go in the PUP before the trip by IGYPup
[Today at 11:48:24 AM]


Anyone use mats from Ocean State Job Lot? by SteveM_CT
[Today at 11:46:02 AM]


Weekend camping warriors by Kimmygr
[Today at 11:41:15 AM]

PopupGizmos Solar Bunk Liner kit (PSBL)
See fewer ads! Become a free PopUpPortal member. Click here to Register

Author Topic: Rockwood 1640 ltd  (Read 1554 times)

0 Members and 1 Guest are viewing this topic.

Offline warrenm

  • Camper, 2nd Class
  • *
  • Posts: 16
    • CA [CA]
    • US [USA]
    • View Profile
Rockwood 1640 ltd
« on: June 26, 2008, 07:26:24 PM »
I have a 2007 Rockwood Freedom 1640 LTD 8ft, just purchased last week. I seem to be having a little trouble with the sink. No water comes out. I flipped the switch on for the pump, nothing. I also tried to drain old water by turning the knob, on the under seat container. No water came out the bottom of trailer or through (grey water outlet?). Also the pump switch makes a churping sound when it's off, stops when on. Help greatly appreciated.


Offline Digger

  • Eagle Camper
  • *****
  • Posts: 3,785
  • Gender: Male
    • VA [VA]
    • US [USA]
    • View Profile
    • My Pics Website
Rockwood 1640 ltd
« Reply #1 on: June 26, 2008, 07:44:53 PM »
Welcome to the Portal Warren!

Let's clarify here....you have a freshwater tank under your dinette seat.  It is full, and doesn't pump through to the sink after you've turned the pump on and opened the faucet.

Sounds like it may be a bad pump, or an empty tank.  Are you sure that the safety cutoff switch is turned off appropriately?  The churping noise when off certainly doesn't sound correct...did someone rewire the pump or the switch at some point?

~Cheers~ igger
'04 Fleetwood Westlake (StonyBlue)/'02 Ford E-150
2008 nights camping: PUP - 13
~Cheers~  igger
'04 Fleetwood Westlake (StonyBlue)/'02 Ford E-150
Nites camped: 2007-8, 2008-39, 2009-50 (camped every month), 2010-14, 2011-14

Offline warrenm

  • Camper, 2nd Class
  • *
  • Posts: 16
    • CA [CA]
    • US [USA]
    • View Profile
Rockwood 1640 ltd
« Reply #2 on: June 26, 2008, 08:25:31 PM »
Yes, I have a freshwater tank under the dinette that is full.  The water was left there from a previous owner.  I turned the faucet on and the pump, no water in sink.  I then tried to turn knob on tank itself under dinette, opened grey water pipe on outside of trailer.  Water will not drain from tank.  

Where is the safety shut off valve located?  

It does appear that the pump switch is backward, on is off, etc.

Is the churping a low battery alert?

Thank You


Offline Digger

  • Eagle Camper
  • *****
  • Posts: 3,785
  • Gender: Male
    • VA [VA]
    • US [USA]
    • View Profile
    • My Pics Website
Rockwood 1640 ltd
« Reply #3 on: June 26, 2008, 08:31:56 PM »
Yep, the chirping may be a low battery alert...I'm not sure how Rockwood does things.  The safety cutoff switch may be located under your galley (if it is a folding galley), or sometimes they are located on the top edge of the camper box so the roof depresses the switch when down in the travel position.

Did you try turning the faucet on when the pump was making it's chirping noise?

Have you checked the fuses/breakers in the converter whcih is usually located under the dinette or couch?

~Cheers~ igger
'04 Fleetwood Westlake (StonyBlue)/'02 Ford E-150
2008 nights camping: PUP - 13
~Cheers~  igger
'04 Fleetwood Westlake (StonyBlue)/'02 Ford E-150
Nites camped: 2007-8, 2008-39, 2009-50 (camped every month), 2010-14, 2011-14

Offline warrenm

  • Camper, 2nd Class
  • *
  • Posts: 16
    • CA [CA]
    • US [USA]
    • View Profile
Rockwood 1640 ltd
« Reply #4 on: June 26, 2008, 09:04:52 PM »
There is a red button under the galley, I read on this portal that it controlled the lights.  Afraid to press red button. I will have a look at the fuses, but the pump did turn on briefly.  I believe the low battery is causing the trouble.  When I was plugged into shore power though, the water still did not drain from under the dinette.  Is the pump also necessary to drain water using the valve located under the dinette?


Offline Digger

  • Eagle Camper
  • *****
  • Posts: 3,785
  • Gender: Male
    • VA [VA]
    • US [USA]
    • View Profile
    • My Pics Website
Rockwood 1640 ltd
« Reply #5 on: June 26, 2008, 09:20:55 PM »
It shouldn't be necessary for the drain.  The switch under the galley is a safety cutoff switch that should turn off the overhead lights and the water pump (I think) when you place the galley in the travel position.  This is so you don't accidently leave the lights on and burn up the camper.  If your lights work when the galley is up, then that switch isn't the issue.

You may want to disconnect the outlet from the pump to see if water is coming out of the pump when it is on.  If so, then you may have a kink in the line between the pump and the sink.

Is this camper still under warranty?  That may be your easiest solution!

~Cheers~ igger
'04 Fleetwood Westlake (StonyBlue)/'02 Ford E-150
2008 nights camping: PUP - 13
~Cheers~  igger
'04 Fleetwood Westlake (StonyBlue)/'02 Ford E-150
Nites camped: 2007-8, 2008-39, 2009-50 (camped every month), 2010-14, 2011-14

Offline warrenm

  • Camper, 2nd Class
  • *
  • Posts: 16
    • CA [CA]
    • US [USA]
    • View Profile
Rockwood 1640 ltd
« Reply #6 on: June 26, 2008, 09:25:41 PM »
Thank you for the suggestions.  I'll see what works.  No warranty, bought the pup used, dirt cheap.


Offline Digger

  • Eagle Camper
  • *****
  • Posts: 3,785
  • Gender: Male
    • VA [VA]
    • US [USA]
    • View Profile
    • My Pics Website
Rockwood 1640 ltd
« Reply #7 on: June 26, 2008, 09:36:49 PM »
Always a good way to get a pup Big Smile

Hopefully another Rocky owner will give you some further insight....

~Cheers~ igger
'04 Fleetwood Westlake (StonyBlue)/'02 Ford E-150
2008 nights camping: PUP - 13
~Cheers~  igger
'04 Fleetwood Westlake (StonyBlue)/'02 Ford E-150
Nites camped: 2007-8, 2008-39, 2009-50 (camped every month), 2010-14, 2011-14

Offline warrenm

  • Camper, 2nd Class
  • *
  • Posts: 16
    • CA [CA]
    • US [USA]
    • View Profile
Rockwood 1640 ltd
« Reply #8 on: June 26, 2008, 09:52:51 PM »
WinkThanks again, and congratulations on the moderator promotion.


Offline Gambit...

  • Camper, 1st Class
  • **
  • Posts: 288
    • MO [MO]
    • US [USA]
    • View Profile
Rockwood 1640 ltd
« Reply #9 on: June 27, 2008, 05:31:30 PM »
I had this problem with my Rockwood.

I bought it used, the water tank was half-full and the hand pump, the elctric pump nor the drain would work.
City water did work.

Turns out, the tank was full of little plastic shavings from when it was manufactured. They had gotten into EVERYTHING!!! Clogging it all up!

I ran a siphon down into the tank from the filler neck and siphoned all the old, foul smelling water out, removed the tank, all hoses, pump and faucet and cleaned it all out.

I installed a filter screen between the pump and the tank and put it all back together and all is well.

Kim

'95 Rockwood Freedom 1940
'87 Volvo 245
"Give me Yellow Death, Silver Magic and a Blue Tip Wrench and I can fix anything!"

Offline Digger

  • Eagle Camper
  • *****
  • Posts: 3,785
  • Gender: Male
    • VA [VA]
    • US [USA]
    • View Profile
    • My Pics Website
Rockwood 1640 ltd
« Reply #10 on: June 27, 2008, 05:35:50 PM »
Excellent thoughts Kim.  Always good to have the experience around here....

~Cheers~ igger
'04 Fleetwood Westlake (StonyBlue)/'02 Ford E-150
2008 nights camping: PUP - 13
~Cheers~  igger
'04 Fleetwood Westlake (StonyBlue)/'02 Ford E-150
Nites camped: 2007-8, 2008-39, 2009-50 (camped every month), 2010-14, 2011-14

Offline warrenm

  • Camper, 2nd Class
  • *
  • Posts: 16
    • CA [CA]
    • US [USA]
    • View Profile
Rockwood 1640 ltd
« Reply #11 on: June 28, 2008, 10:27:41 PM »
I took the PUP out camping yesterday, hooked it up to a 30 amp connection at the campground. The pump and sink started working fine.  The 1640's heater did not work when I bought (how I negotiated dirt cheap price).  I plugged in a 1500 watt heater to the shore power.  Camper stayed warm and toasty.  I am hooked on PUP camping, should have bought one years ago.