2004 coleman niagara elite water pump

Discussion in 'First Time & New Camper Owners' started by Chris Leasure, Feb 12, 2019.

Tags:
  1. Chris Leasure

    Chris Leasure New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Feb 12, 2019
    I just bought a 2004 coleman niagara elite last week Everything worked perfectly when I bought it. Checking everything out just now and the water pump won't come on at all Tried 120 and 12 volt, switch is on, sink/stove are in the upright position and the tank is full. Checked all 4 fuses on the converter, but all are good Am I missing something??
     
  2. BikeNFish

    BikeNFish Well-Known Member

    Messages:
    2,220
    Likes Received:
    1,267
    Joined:
    Apr 24, 2017
    Location:
    Maplewood, MN
    Hello and welcome from Minnesota!

    Check to see if it has a filter screen or filter and make sure it is not clogged. Maybe filling the water flushed something through the lines.
     
  3. Chris Leasure

    Chris Leasure New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Feb 12, 2019
    Checked, but no dice. Thanks though
     
  4. PopUpSteve

    PopUpSteve Administrator

    Messages:
    18,037
    Likes Received:
    1,051
    Joined:
    Dec 22, 2002
    Location:
    Malvern, PA
    Water in the tank?
     
  5. Chris Leasure

    Chris Leasure New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Feb 12, 2019
    Yeah, completely full
     
  6. GreyFox

    GreyFox Active Member

    Messages:
    589
    Likes Received:
    209
    Joined:
    Oct 10, 2018
    Location:
    S Ontario
    In any Fleetwood camper I've owned that had a water pump there was a 7.5 amp inline fuse in the + near the pump. Pump won't run if it's not seeing +/- 12 vdc so time to break out the voltmeter and see if it is.
     
  7. Chris Leasure

    Chris Leasure New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Feb 12, 2019
    Thanks, I'll give that a shot
     
  8. jmkay1

    jmkay1 2004 Fleetwood/Coleman Utah

    Messages:
    4,061
    Likes Received:
    998
    Joined:
    Oct 10, 2013
    Location:
    Northern Virginia
    Could the switch have gotten gummed up. Sometimes you have to play around with the switch a few times to get the full connection. When you crawl in the slide out where the pump is located do all the appropriate wires and hoses appear attached?
     
  9. Chris Leasure

    Chris Leasure New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Feb 12, 2019
    The switch seems fine (not sticky and toggles off and on fine). Right now my issue is that I can't seem to find the actual pump. I've crawled under, traced all the water lines, pulled the drawers out from under the sink, etc. Can anyone tell me the location?
     
  10. jmkay1

    jmkay1 2004 Fleetwood/Coleman Utah

    Messages:
    4,061
    Likes Received:
    998
    Joined:
    Oct 10, 2013
    Location:
    Northern Virginia
    . The pump is actually hiding inside the step to the slide out. There are about 5 screws you need to undo on the kickplate and the pump is behind that.
     
    Chris Leasure likes this.
  11. Chris Leasure

    Chris Leasure New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Feb 12, 2019
    Thank you so much! I was starting to wonder if I was going crazy.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.