3-way in Fleetwood E1 not cooling

Discussion in 'Refrigerators and Coolers' started by bdhtx, Nov 2, 2017.

  1. bdhtx

    bdhtx New Member

    5
    0
    Sep 19, 2016
    My 2008 E1 has the standard 3-way. I did all the baffle mods, two fans, and a fan inside.

    It is not cooling. I know it is getting hot because the fans come on, but it is not getting cold inside. That is on 110.

    Suggestions?

    One post said to pull it out and flip it over!
     
  2. 94-D2

    94-D2 Happy Campin'

    2,279
    82
    May 21, 2010
    Sutter Creek CA
    See what it does on gas. But, I’m sure the issue is greater than that. I don’t know about flipping it over, but I understand the ammonia can seize or clog (crystallize)Taking it on a rigorous ride could jolt the contents enough to get it back. If the ammonia seizing is the problem, it’s done. No fixing it. Also check that the burner or heat element (chamber) is clear. It might be getting hot, but not in the correct places.
     
  3. theseus

    theseus Centerville, OH

    2,216
    124
    Feb 6, 2007
    Centerville, OH
    x2^

    I would also definitely check for any spider or wasp nest in the areas that are supposed to be getting hot. My campers refrigerator wasn't heating on propane. After a good cleaning it would light, but I had to replace the orifice AND clean out the stack.

    Check for any yellow/brownish powder around the coils. That's residue from leaking refrigerant. If you find it in sizeable amounts, then your refrigerator is done.
     

Share This Page