Pump runs but no water

Discussion in 'Miscellaneous Repairs & Maintenance' started by Ron Bolton, Aug 22, 2018.

  1. Ron Bolton

    Ron Bolton New Member

    3
    0
    Aug 22, 2018
    Colorado
    I have a 1998 Coleman Cheyenne pop up.
    This season the water pump is not delivering any water to the sink.
    This is a simple pop up with no shower or toilet just a sink.
    At first I noticed the airline to the water tank was filled with debris that seem to be from insects.
    When I cleaned that out there was no change. I took off most of the water lines and checked for clogs and did not find any.
    The pump runs and sounds what I think is normal. But no water comes. When I reconnected it I might have mixed up and connected the external water fill tube to the wrong port on the faucet; that is, I might have put it where one of the lines from the pump is supposed to connect. But I swapped and tried it both ways.
    In one of the waterlines I did find a small filter but it was not clogged.
    Do I need to take apart the pump? Or perhaps the faucet?
    I’ll appreciate any guidance!
    Thanks
    Ron
     
  2. Arruba

    Arruba Active Member

    206
    52
    Nov 28, 2014
    Central Oregon
    These basically have a paddle wheel/positive displacement type pump. As you have checked the lines and filter, the next guess would be the impeller. The impeller is a little rubber wheel inside the pump where the lines connect. They sometimes get brittle with age, or gummy if you use RV Antifreeze to winterize. The shaft then spins without turning the impeller and thus no water. The wheel type can be fixed by removing the base plate and changing the wheel and key shaft. If is truly a diaphragm pump, then its change the diaphragm, those in an RV size pump, the head unit are usually sealed, thus requiring a new head. Odds are yours is a wheel type. The other problem may also be a bad seal on the suction side of the pump in ether the line or gaskets. If your filter is on the suction side and has a screw on type filter case, sometimes they don't seal well.

    Good luck
     
  3. Ron Bolton

    Ron Bolton New Member

    3
    0
    Aug 22, 2018
    Colorado
    Thanks for the info! It helped knowing that there were experts to back me up with info!
    I got it working!
    It turned out that my pump is one with 2 diaphragms and I guess there was not a good seal or a microscopic piece of debris. When I put it back together and tried it, it worked.
    Certainly the clogged air line to the tank was part of the original problem too.
    Followup question....for testing it I did not want to reinstall it in the popup because it is in an awkward place in back of a cabinet. So I wanted to touch the pump wires to battery terminals and have the input water line in a bowl of water. That worked, but I didn't know for sure if I could use the large battery directly or if that would be too much and damage it. Someone suggested I needed to hook it up to a small battery to test. That is what I did. The question is if the power coming down from the pupup battery is divided or limited in the wiring so I should not test directly to it. Just curious as the problem is solved at this time.
     
  4. erond

    erond Member

    65
    39
    Aug 10, 2018
    Northern Virginia
    The 12V from the battery is the same throughout the pup. Some of the fuses protecting "branch circuits" could be larger or smaller to provide the right protection against overload.

    The pump is not going to take any more power from a small battery than a big one. The only concern when going directly to the battery is in the case of a short circuit. Both batteries will spark and likely melt the wires, but the big battery would catastrophically disintegrate them. Fire and shrapnel are the concerns. However, that's the same concern for any short circuit, it's not just the pump.
     

Share This Page