Water pump not sealing?

Discussion in 'Plumbing Systems (The Fresh, The Blue, The Grey, &' started by mountain mike, Jul 28, 2018.

  1. mountain mike

    mountain mike New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Jul 25, 2017
    Been chasing a leak for a little bit. I disconnected the inlet from the water pump, plugged it with my finger, ran the pump and was unable to get the pump to stop running. Look off the outlet and plugged it with my finger and also could not get the pump to turn off. Could this mean my pump is not sealing and is causing the leak? It is leaking sometimes around that area but not all the time and I can’t figure out where the water is dripping from when it does leak.
     
  2. joet

    joet Well-Known Member

    Messages:
    3,992
    Likes Received:
    671
    Joined:
    Mar 16, 2011
    Location:
    Elkins WV area
    By removing the pump intake line, the pump will run because there isn't any water to build pressure to shut it off. If the pump will not shut off with the outlet plugged and there is water on the inlet side,,, pump is bad
     
  3. mountain mike

    mountain mike New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Jul 25, 2017
    ^^thanks. I also just hooked up to city water and everything works great with no leaks. Off to replace the pump. :)
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.