White LED strip from 2015 Starcraft Hybrid

Discussion in 'FreeCycle' started by JimmyM, May 29, 2017.

  1. JimmyM

    JimmyM Well-Known Member

    1,809
    249
    Jun 5, 2014
    Franklin, MA
    I just removed the white LED strip from my 2015 Starcraft 239TBS. It works fine and I can power it up before you take it. It's the complete unit, mounting rail and LED strip.
    The mounting rail is black plastic. It's about 16-17' long.
     
  2. Sneezer

    Sneezer Well-Known Member

    1,155
    312
    Aug 8, 2015
    DFW, TX
    I would be interested in picking it up but I am in Texas. I seem to recall you are in the NE somewhere. Shipping would be a killer as I assume it is a rigid mounting track.
     
  3. JimmyM

    JimmyM Well-Known Member

    1,809
    249
    Jun 5, 2014
    Franklin, MA
    Yup. Right on both counts.
    I'm in Massachusetts.
    The track is rigid. Trying to coil it would destroy it I think
     
  4. MikeRule

    MikeRule Member

    36
    1
    Nov 19, 2017
    South Shore, MA
    Hi JimmyM - Any chance you could throw up a pic? Not quite sure what the unit is, but as I'm LEDifying my camper, sounds like I might be able to put it to use.
     
  5. JimmyM

    JimmyM Well-Known Member

    1,809
    249
    Jun 5, 2014
    Franklin, MA
    I don't have any pics. But it's a black plastic strip about 1-1/4 inches tall with a round channel at the bottom that holds a round clear plastic strip with white LEDs. Are you in the eastern MA region?
     
  6. MikeRule

    MikeRule Member

    36
    1
    Nov 19, 2017
    South Shore, MA
    Hi - Yes; I live in the South Shore, work around Boston/ Cambridge, with semi-regular trips to Hopkinton and the North Shore. Fairly certain I can find a use for it if you would like to coordinate.
     
  7. JimmyM

    JimmyM Well-Known Member

    1,809
    249
    Jun 5, 2014
    Franklin, MA
    I'm sure we can work something out. Maybe this weekend.
    PM me.
     

Share This Page