Atwoo Hydro Flame 7900 (Bad Board)

Discussion in 'Heating / Cooling Systems' started by steppinthrax, Apr 20, 2014.

  1. steppinthrax

    steppinthrax Member

    Messages:
    181
    Likes Received:
    0
    Joined:
    Aug 7, 2013
    So we went camping this weekend. The gas furnace was working nice for the 2 nights. The last propane tank ran completely out and the furnace tried to fire. The blower came on and you could hear a clicking noise, but no gas. I cut off the furnace and replaced the empty tank with a full one. When trying the furnace again the blower would come on but would not do any clicking or the gas solenoid wouldn't open. I figured it must be some "lock-out" or some safety feature. I tried cutting the power for a few minutes and shutting on/off the circuit breaker within the furnace, still the furnace would not light. All the other gas appliances work!!!

    I finally went home and pulled the furnace apart. I tested the gas solenoid, sail switch and other components. It appears power is getting to the control board, but the board is not sending out a spark or opening the control valves!!! So it seems my board is bad. I see boards online going for around 120!!!! Do you know if there is a cheaper alternative or maybe I'm missing something here!!!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.