Atwood Model 7916-11 Heater will not start.

Discussion in 'Heating / Cooling Systems' started by Charles, Oct 11, 2019.

  1. Charles

    Charles New Member

    Messages:
    29
    Likes Received:
    2
    Joined:
    Sep 25, 2014
    Location:
    Oregon
    Good Morning, I have a 2011 Coleman E1 with the above heater. Since we are normally hooked up to power I just carry a small electric heater to provide the heat that we need, so I have only used the onboard heater a couple of times. I was off-road camper a few days ago and went to use the heater and it wouldn't start. I have a new battery so I figure it wasn't a power problem. There is a Off/Reset switch on the heater, which I found in the off position. Is that the correct position for that switch? Any suggestion would greatly be appreciated to get this heater working. Thank You.
     
  2. PopUpSteve

    PopUpSteve Administrator

    Messages:
    18,873
    Likes Received:
    1,614
    Joined:
    Dec 22, 2002
    Location:
    Malvern, PA
    Have you ever used it?
     
  3. Charles

    Charles New Member

    Messages:
    29
    Likes Received:
    2
    Joined:
    Sep 25, 2014
    Location:
    Oregon
    I used it maybe twice in the time I have owned the popup......I brought a new thermostat and I finally got a red light on the control to start flashing, but no fan. So I pull the control board out and went down and tested the board and it was bad. After ten years and really never has been used, but the weather has that kind of effect on electronics......installed the new board and turned on the thermostat and I finally have heat.
     
  4. Pooch

    Pooch New Member

    Messages:
    14
    Likes Received:
    2
    Joined:
    Aug 29, 2019
    Turn the "Off" switch to Reset or On and and it should work.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.