blinking diagnostic error on Atwood 7916 furnace

Discussion in 'Heating / Cooling Systems' started by lars, Jul 14, 2009.

  1. lars

    lars New Member

    Likes Received:
    Jun 16, 2009
    White Rock, British Columbia, Canada
    In our new-to-us 2003 Fleetwood Sea Pine, the furnace stopped working. It worked at the dealership a month ago, and I also tested it at home just under a month ago. Since then, the pup sat outside (without being plugged in) for about 2-3 weeks. I also changed a leaking water pump. And I disconnected the propane tank to install a tee splitter (so I could use high pressure stoves for outside use).

    Since doing all this, I have run both burners on the inside stove and the fridge on propane successfully. but the furnace will not start. These are the symptoms:

    [list type=decimal]
    [*]I turn on the power switch on the thermostat.
    [*]The furnace fan starts up.
    [*]Outside the trailer, near the furnace exhaust, I can smell propane.
    [*]After a few seconds, I can hear the furnace making multiple sparks, trying to light the gas.
    [*]Then the sparking stops, as does the gas smell.
    [*]This cycle repeats again (fan for a while, then gas, then sparking).
    [*]I never hear the furnace actually light.
    [*]After a while, the fan shuts off, and I see the LED blinking 3 times, pause for 3 seconds, and then blink 3 times again, and this blinking/pause cycle continues until I shut off the switch at the thermostat.

    I have tried reseting the circuit breaker on the interior control panel of the furnace.

    I have unplugged the control board and re-installed it, in an effort to reset the board.

    Does anyone have suggestions for how to trouble shoot this problem? Ordinarily I'd think it is related to the fact that I recently disconnected/reconnected the tank but since the stove and fridge work fine, I assume the gas is ok.

  2. Zoltar

    Zoltar New Member

    Likes Received:
    Jun 2, 2009
    I have this same furnace in my Jayco. You should have a sticker on your blower assembly
    giving you the fault codes, but I'll post them here for you.

    Fault LED Indication

    Internal Circuit Board fault Steady on, no flashing

    Limit switch/Airflow problems 1 flash with 3-second pause

    Flame Sense fault 2 flashes with 3-second pause

    Ignition Lockout Fault 3 flashes with 3-second pause

    So it appears you have an ignition lockout fault.
    That would mean that the electronics is not detecting a flame that MAY be there.
    Maybe a bad ground at the electronic board.
    Or, the sparking you hear may not be taking place at the place it should be.
    Possibly a bad spark electrode or high tension wire.

    A "flame sense fault" would mean that the board sensed the flame at trial for
    ignition, but then lost the flame signal.

    This electronic board senses the flame thru flame rectification.
    Basically, a flame will pass a DC electrical current. In this case thru the spark electrode to ground (the burner).
    So your "spark wire / electrode" is also part of your flame sensing circuit.

    To reset your board all you need to do is:
    1. Turn your t-stat on off switch off.
    2. Turn down the temperature so the bimetal points will open.
    And wait for the fan to shut off, if it hasn't already.

    To restart, flip the switch back on and turn up the t-stat.

    You can go to the Atwood site at :
    There is some information here and a trouble shooting guide.

    BUT remember you are working with LP gas, be very careful. If you are the least bit unsure of what you are doing,
    please take it to a dealer. It's better to pay a few bucks and be uninjured and still go camping.

    Just reread your note.
    Try shutting off your tank, light your stove to burn off the gas (reduce the pressure in the gas line) then turn off stove.
    Then S L O W L Y reopen your tank. There was a thread describing how by opening the valve to quickly will cause the
    regulator to stick. Gas will flow but not at a large enough volume for the furnace to work.
    Don't ask how I personally know this. [:(!]
  3. fliflo

    fliflo New Member

    Likes Received:
    Aug 28, 2011
    Thanks a lo,t I had an ignition lockout problem, I opened the gas tank slowly and magically worked. Regards for the simple solution.
  4. lars

    lars New Member

    Likes Received:
    Jun 16, 2009
    White Rock, British Columbia, Canada
    Zoltar, thank you very much for the detailed reply, and my apologies for such a late response. I somehow missed your reply the first time. FWIW I have tried the ol' "open the tank valve slowly trick" but that didn't fix the problem. Even with the tank opened, and the stove working, the furnace might come on one time, and then not come on any time after that. Or it'll fail for a few times, and then come on. It's very sporadic.

    The only constant is the blinking err. code. I've got the trailer in storage right now but when things warm up, I will figure this problem out, one way or the other.

  5. lars

    lars New Member

    Likes Received:
    Jun 16, 2009
    White Rock, British Columbia, Canada
    Excuse me while I resurrect this thread from the dead...

    I finally got around to fixing the problem. I tried a variety of things:
    - Removed the sparker and tested it. Worked fine...strong spark.
    - Adjusted the stove's gas regulator 2 stops out, then 2 stops in, just because I read somewhere that it fixed someone's problem before. Didn't help me.
    - Checked the anticipator in the thermostat. I realize that it sounds weird that it would have anything to do with the problem, but someone with the exact same symptoms as mine swears that adjusting it fixed his problem. My anticipator was set almost to zero, which was weird since it's supposed to be above the .48 mark. So I set it to betwen .48 and 1. But like I said, it didn't help.
    - Removed furnace valve and peered through the port and the valve body. Looked fine.
    - Removed burner unit and cleaned out 2 or 3 of the holes in the mesh since they had some junk in them.
    - Cleaned out the flame chamber...there was a large bumble bee carcass in there.
    - Put an air hose in the chamber and blew out the ducting.
    - Inspected the vent port on the outside of the trailer.
    - Had the sparker / sensor unit tested at an RV shop.
    - Had the controller board tested at an RV shop.

    None of the above fixed the problem. So then I decided to adjust the main pressure regulator. I turned it clockwise 2-3 full turns. That caused the furnace to start more frequently, but still not consistently. It did, however, result in a slight change.

    Before, the symptoms were:
    1. Turn on the furnace switch.
    2. Blower runs for 15 or so seconds.
    3. Gas flows (I know there's gas flowing because I can smell it).
    4. Igniter starts sparking continuously for about 3 seconds.
    5. Furnace doesn't light. After 15 seconds, repeat steps 3 & 4, then repeat 3 &4 again.
    6. Flash the LED error code.
    7. Blower shuts down after 15 seconds.

    Now, after adjusting the pressure regulator, the steps are the same as above except:
    4. Igniter starts sparking and stops after maybe 1/4 seconds. I can hear a pop, like the gas lit and then went out. Then the sparking continues with maybe another pop and pause in the sparking. Other times, it catches and stays lit. But usually on the 2nd or 3rd sparking cycle.

    So basically, it's more likely to start after adjusting the pressure regulator. Thinking that I was on the right track, I built a manometer, hooked it up to the fridge's gas line, and then tested the pressure.

    With the 2 stove burners on maximum, and the furnace running (it just happened to run for my test), the manometer showed 9 inches of water. The proper pressure with those appliances on should be around 11 inches. So I turned the pressure regulator adjuster clockwise several times (6 or so) until it was at 11 inches. Then I shut down the furnace and stove. With all the appliances turned off, the pressure rose to 12.5 inches. That was good, because the requirement is that it not go above 14 inches.

    When I tested the furnace after the adjustment, the furnace lit within a tiny fraction of a second after the igniter starter sparking. And it did this very consistently, always on the very first spark cycle.

    I never suspected that the gas supply could be the problem since our fridge and stove worked fine. But I guess the problem with the furnace is that it has a very wide burn area (ie: there's not a single, narrow point of flame) so there just wasn't a high enough concentration of propane finding its way to the sparker during the furnace lighting the chamber is being vigorously ventilated by the blower.

    So, for anyone who has this problem (and I've seen it several times on the web), check your gas pressure, first. It could save you a lot of trouble.
    MikeRule likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.