DSI system stopped working - furnace, water heater, ref furnace igniters stopped working

Discussion in 'Heating / Cooling Systems' started by Hearty Sarsoza, Oct 13, 2019.

  1. Hearty Sarsoza

    Hearty Sarsoza Member

    Messages:
    72
    Likes Received:
    12
    Joined:
    Apr 5, 2019
    Good day everyone! I'm needing some help we are up in the mountains of Oklahoma camping and all my igniters (DSI) just stopped working. It was working fine since yesterday and when I woke up today my furnace heater was off and wouldn't seem to ignite. Water heater and ref igniters stopped working as well. I have a 2007 Fleetwood Niagara. I'm hooked up to 30 amp shore power and my battery is fairly new. Hope to find answers thanks very much.
     
  2. Raycfe

    Raycfe Waterford Ct.

    Messages:
    15,186
    Likes Received:
    1,419
    Joined:
    Oct 3, 2007
    Location:
    Waterford, Ct
    There are only 2 things that the DSIs have in common ........ 12 power to operate and propane.
    My first guess is you have a propane problem ........ out of ...... or bad regulator.
     
    Sjm9911 and Hearty Sarsoza like this.
  3. Hearty Sarsoza

    Hearty Sarsoza Member

    Messages:
    72
    Likes Received:
    12
    Joined:
    Apr 5, 2019
    Thanks for the input. I tried to light the stove burner and it lights up pretty easily with blue flame. The pilot light also on my water heater works perfectly but would not fire on the burner. The furnace blower works good and attempts to ignite but after about 2 mins will just turn off.
     
  4. Hearty Sarsoza

    Hearty Sarsoza Member

    Messages:
    72
    Likes Received:
    12
    Joined:
    Apr 5, 2019
    It worked again. I opened up the furnace grill and resetted the system now it's back working. Thanks
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.