Help please!

Discussion in 'Wiring' started by RSH, Jan 3, 2016.

  1. RSH

    RSH Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Jun 14, 2015
    I've tried to follow the advice of everyone that responded to my original post. I checked the connections that go to the battery (when there was a battery installed) and nothing out of place - wires well insulated, none touching or grounding out. I've checked for loose connections throughout the camper and can't find any. As far as I can tell the propane leak detector, inside roof lights, and the outside light (next to the door) all run on this 12V circuit. And when the trouble, starts all 3 of these gadgets starting blinking/beeping simultaneously. If a single loose wire was the cause of all this, where is it most likely located? Would a loose wire to any one of these devices cause the whole system to freak out?
     
  2. rabird

    rabird Howdy!

    Messages:
    6,662
    Likes Received:
    284
    Joined:
    Mar 3, 2006
    Location:
    TX
    at some point inside the box, the 120v powers the converter. This supply of 120v via a breaker (shared or one dedicated to the converter) could be your culprit also could be loose.

    the 12v side is all distributed out the back thru a plastic plug, this (and/or the front on each side of the fuses) is a good place to test with a volt meter.
     
  3. RSH

    RSH Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Jun 14, 2015
    I suspect my problem is with the breaker for the 12V circuit. I have disabled the 12v circuit for now by pulling the 30 amp fuse from that circuit. I can live without the interior lights and the propane leak detector until I return home from this trip. Once home I will hire an electrician to track down the problem - I want to be certain I fix it before the next trip. -Robert
     
  4. Kitrina

    Kitrina Member

    Messages:
    36
    Likes Received:
    5
    Joined:
    Mar 31, 2019
    Location:
    DFW TX Area
    Hi there. Jumping in on this therad
    Hi. Did you ever find out what the issue was? I have similar issues with an 07 Niagara.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.