Loud popping noises when cranking up 1997 Coleman Sun Valley

Miss Karla

Member
Jul 10, 2017
43
Actually when I took the back off &got a look at things, the problem ended up being a very simple fix & cost me basically nothing! There was too much slack in the chain & it was slipping. I added some washers I had laying around to take the slack out & voila! Problem fixed!
 

Attachments

  • 83aa8276-b2dd-4ac4-a5fb-dcd4f1e1e11c.png
    83aa8276-b2dd-4ac4-a5fb-dcd4f1e1e11c.png
    160.2 KB · Views: 29

KJMcNeil

Member
Aug 22, 2018
80
Salt Lake City, UT
This is a Reminder for you to Not spray the anything on the pressure disc in the lift crank or you will be disassembling the whole crank to clean it off.

What is the pressure disc? Can't seem to find a pic. I got desperate and sprayed stuff with wd-40 while trying to get the top down at a lake 100 miles from home.
 

MisterKlister

New Member
Sep 21, 2019
5
Madison, WI
Man, I cant thank this site enough..2 "issues" with a 2005 Bayside that we bought last weekend..Roof (on its way to being repaired) and then the lift system which is making a loud popping noise when cranking up. Do get the little clicking, but it's almost as if every two "teeth" the chain goes over, i get what i think is a slip and the loud noise. I pulled the wiffle tree cover off last night and all looked fine, grease on it (although could probably use more) and the noise was coming from the upper assembly. Probably going to remove the back panel tonight. Also, seem to be having a bit of an issue w/ the roof not staying up if not fully raised. Handle wants to move backward, which a bungee cord holding will prevent. If raised all the way, it seemed to click and stay. Wondering if there its dirty on the brake disc..
Attached a video of what i've got going on for the noise.
1. Chain need to be tightened do you think or something else possibly? Suggestions of what to look for?
2. Other things to look for once i remove the rear panel
3. Use a teflon lube for the chain, right?

The campersolutions guy is awesome! Thats a resource to save!!!

Thanks for the help and suggestions!!

 

Miss Karla

Member
Jul 10, 2017
43
Mister Klister, based on your video, you are definitely going to have to take the back panel off your camper & get a better look at the chain mechanism. If your lucky, it's just too much slack in the chain. Literally a few penny washers might fix the problem. Start with that. Good luck! Could also be you've lost a tooth or two in the cog mechanism, causing the chain to slip...? I'd check those simple solutions out first!
 

brdeel

Member
Apr 27, 2018
56
CO
Man, I cant thank this site enough..2 "issues" with a 2005 Bayside that we bought last weekend..Roof (on its way to being repaired) and then the lift system which is making a loud popping noise when cranking up. Do get the little clicking, but it's almost as if every two "teeth" the chain goes over, i get what i think is a slip and the loud noise. I pulled the wiffle tree cover off last night and all looked fine, grease on it (although could probably use more) and the noise was coming from the upper assembly. Probably going to remove the back panel tonight. Also, seem to be having a bit of an issue w/ the roof not staying up if not fully raised. Handle wants to move backward, which a bungee cord holding will prevent. If raised all the way, it seemed to click and stay. Wondering if there its dirty on the brake disc..
Attached a video of what i've got going on for the noise.
1. Chain need to be tightened do you think or something else possibly? Suggestions of what to look for?
2. Other things to look for once i remove the rear panel
3. Use a teflon lube for the chain, right?

The campersolutions guy is awesome! Thats a resource to save!!!

Thanks for the help and suggestions!!


For mine it was the chain. Mine was all stretched out and sagging. I added two washers to each bolt to lengthen the chain. I also degreased the chain and the wiffle tree with mineral spirits and put chain spray lube on the chain and moly on the wiffle tree. Works great now. The roof not staying up can have something to do with the brake in the crank assembly.

Good luck!
Bridget camper workshop close.JPG chain 1 loose.JPG Chain washer 2.JPG Chain clean and shiny.JPG
 

FARfetched

Active Member
Nov 22, 2018
743
Sector 706, Planet Georgia
Nothing but respect for brdeel and Miss Karla, who powered through to solutions!

Chains do stretch over time. Motorcyclists will tell you what happens is that the holes in the links elongate, effectively making the chain longer… the longer the chain, the less elongation per link it takes to have a noticeable effect. Popup lift chains obviously don't have the stress that motorcycle drive chains are subject to, but there's a fair amount of torque, and it's easy for POs to ignore stuff not in plain sight, right? [::)]

What I'm saying is, you'll have to take out the washers and replace those chains in about 10 or 20 years. [LOL]
 

Miss Karla

Member
Jul 10, 2017
43
See attached link: page 7 / 44 https://cdn.shopify.com/s/files/1/0273/4347/files/2000_coleman_grand_tour.pdf?16695232820753828628
The main ratchet bearing sounds like it is either bad or very close to being there. As mine had same issue.
See part number 4745H6101 which is part number 22 on the diagram.
It runs $ 320.
See link: https://colemanpopupparts.com/products/crank-assembly-8
Hey Babjopikker. Miss Karla here. Now I have a PUP that REALKY does not want to crank up at all. I'm guessing it's time to order the bottom crank drive and replace it. Thoughts??
 

Miss Karla

Member
Jul 10, 2017
43
Man, I cant thank this site enough..2 "issues" with a 2005 Bayside that we bought last weekend..Roof (on its way to being repaired) and then the lift system which is making a loud popping noise when cranking up. Do get the little clicking, but it's almost as if every two "teeth" the chain goes over, i get what i think is a slip and the loud noise. I pulled the wiffle tree cover off last night and all looked fine, grease on it (although could probably use more) and the noise was coming from the upper assembly. Probably going to remove the back panel tonight. Also, seem to be having a bit of an issue w/ the roof not staying up if not fully raised. Handle wants to move backward, which a bungee cord holding will prevent. If raised all the way, it seemed to click and stay. Wondering if there its dirty on the brake disc..
Attached a video of what i've got going on for the noise.
1. Chain need to be tightened do you think or something else possibly? Suggestions of what to look for?
2. Other things to look for once i remove the rear panel
3. Use a teflon lube for the chain, right?

The campersolutions guy is awesome! Thats a resource to save!!!

Thanks for the help and suggestions!!


Uh yeah, your chain is definitely slipping in that video. Try taking a link out or adding a couple washers. Good luck!
 




Latest posts

Top