Power problem, no lights

Discussion in 'Lighting, Interior and Exterior' started by kiv558, Jun 20, 2013.

  1. kiv558

    kiv558 New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    May 26, 2013
    Leaving Saturday for a two-week road trip -- and we have no lights or fan. All outlets work, water pump works, furnace, fridge, everything down low. But two lights and fan on the roof aren't getting any power. I've tried to follow the wiring, but I don't see any issues.

    Any ideas?

    Thanks!
    Rhonda
     
  2. Deskpilot

    Deskpilot Member

    Messages:
    640
    Likes Received:
    1
    Joined:
    Jul 6, 2010
    lights are tied to a kill switch on the galley flip up. Galley has to be UP in order to close the circuit in order for any roof power to get "UP."
    If galley is UP and still no power, check that the wiring on the back of the switch didn't come loose.
     
  3. kiv558

    kiv558 New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    May 26, 2013
    AHHHHH! I'll betcha anything that's it. SO HELPFUL! I'll crank it up tomorrow and test it.

    Thanks a zillion,
    Rhonda
     
  4. teejaywhy

    teejaywhy Active Member

    Messages:
    1,411
    Likes Received:
    11
    Joined:
    Jul 19, 2011
    Unless you have a Jayco, in which case the "kill switch" is located on the edge of the roof, driver's side near the rear lift post.

    Tell us what make and model camper you have and then more specific advice can be offered.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.