Screen filter on water pump 2004 Jayco Eagle select

Campgrandma

Member
Feb 4, 2021
75
Cibolo, TX
On my N2U Jayco we tried to use the water pump to sanitize the the pipes. The pump turned on but wouldn’t pump. Looking at trouble shooting I saw the screen filter could be clogged. However, after looking all over the pump system on this almost 17 year old camper, I do not see a screen filter. Is it possible that one was not installed on a camper of this age? We bought and plan plan to install a new pump. We used the city water on on maiden voyage and thankfully had no issues with the water!
 

WrkrBee

Super Active Member
May 23, 2018
6,544
South Carolina
On my N2U Jayco we tried to use the water pump to sanitize the the pipes. The pump turned on but wouldn’t pump. Looking at trouble shooting I saw the screen filter could be clogged. However, after looking all over the pump system on this almost 17 year old camper, I do not see a screen filter. Is it possible that one was not installed on a camper of this age? We bought and plan plan to install a new pump. We used the city water on on maiden voyage and thankfully had no issues with the water!
Got a picture of your pump to post? Were the valves in the correct position to cut off the pickup to the fresh water tank and open the suction line?
 

Campgrandma

Member
Feb 4, 2021
75
Cibolo, TX
The pup is stored now, but yes, all valves were closed/ opened appropriately and the only system I could see was the pump itself with no screen valve above the pup floor.
 




Top