Think I broke a stabilizer Jack!

Discussion in 'Stabilizing Your Camper' started by Tdogg, Jul 2, 2012.

  1. Tdogg

    Tdogg New Member

    Messages:
    25
    Likes Received:
    0
    Joined:
    May 1, 2012
    Not sure what happened, was a successful trip this weekend, then coming home to setup / air out the PUP, the right rear STA would not come down. It gets maybe an inch down and then stops dead. I do have the screw type, found on a coleman/fleetwood Utah, 2002. Looking at the other three, there are a few washers loose on the broken one, while they are not loose on teh other three. Anyone have any suggestions? May have to take it off the PUP to diagnose/repair. I've already covered it in penetrating oil, in case that was the issue.

    Thanks!
     
  2. cwolfman13

    cwolfman13 Active Member

    Messages:
    3,218
    Likes Received:
    8
    Joined:
    Feb 9, 2011
    I'd pull it off to take a closer look and see if it can be repaired. May need to purchase a new one; like anything, they wear out eventually. By the by, you haven't been using your stabs to level have you? That'll destroy a stab faster than anything.

    Could also be some dirt or grit in there binding it up; perhaps stripped the threads out....maybe rough roads making things come loose.
     
  3. Tdogg

    Tdogg New Member

    Messages:
    25
    Likes Received:
    0
    Joined:
    May 1, 2012
    Thanks, no, I know to use the stabs as stabilizers only. Our last trip to long point, we didn't have a prayer of leveling front to back...all we could do was side to side. I'll likely pull it off as you suggest, now just have to wait for the FL heat to calm down a bit..maybe 1 am?

    Thanks!
     

Share This Page